Most of the DApps exhibit this vulnerability